We would like to finalize the maintenance process by sending a message to the client that includes the release notes. This message is for testing purposes only - please do not reply.
Checking formating
Highlights in This Release
Bulk Ticket PDF Export (Web, iOS, Android) Export multiple tickets at once as either a single PDF or a ZIP of individual PDFs for easier sharing and recordkeeping.
Operational Improvements
Plant lists are now cleaner and more consistent across platforms, especially in Ready-Mix workflows.
This message is for testing purposes only - please do not reply
Posted Feb 20, 2026 - 08:36 UTC
Completed
The scheduled maintenance has been completed.
Posted Feb 19, 2026 - 08:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2026 - 07:00 UTC
Scheduled
BCMI will conduct a product update on the following date and time listed below. Product updates require no or very minimal disruption of service and no down time is expected.
Date and Time: February 19, 2026, 0700 UTC (0300 Eastern)
Purpose: Apply fixes, improvements, and stability enhancements to Material Pro and Material Now
Duration: 1 hour
What to expect: Regular access and functionality of Material Pro and Material Now. Virtually no disruption to data import.
Posted Feb 18, 2026 - 21:11 UTC
This scheduled maintenance affected: BCMI Application (Web) and API.