Material Pro & Material Now Release Notes: 3.38.0.5 / 3.34.0.5
Release window: July 22, 2026 (API + Web) •
Quoting & Pricing
New Features
Add amount based escalator pricing. Quotes flagged for ERP export now use amount based escalators, with percentage escalators locked out so pricing stays valid across systems. Available on web, iOS, and Android.
Add a common quoting flag for primary mixes. Primary concrete mixes can now be marked as common for quoting, on web and mobile.
Add a Mix Restricted default by plant group. The Mix Restricted flag can now default from the plant group, saving setup time on new mixes.
Improvements
Improve cascade quote approvals. A higher level approver is no longer blocked by lower level checks, and a top level approver can act for a missing middle level.
Allow duplicate primary products on opportunities. The same primary product can now be added to an opportunity more than once, on iOS and Android.
Improve PO Required defaults. The PO Required setting now defaults more predictably based on customer and sales office configuration.
Bug Fixes
Fix stale quote bundle prices. A bundle's price now recalculates after editing the prices of its linked products.
Fix product restrictions not being applied. Restricted concrete products are now correctly excluded where they should be.
Orders & Projects
New Features
Add one time Order Memos. A memo can now pop up every time an order is opened until the viewer dismisses it, across web, iOS, and Android.
Show placement method in Order Details. The placement and application method now appears in Order Details in Material Pro and Material Now, including mobile.
Add bulk editing of project dates. Project begin and end dates can now be updated in bulk.
Show project transaction type on orders. Order details now include the project's transaction type.
Improvements
Include custom prices when cloning projects. Cloned projects now carry over their custom prices.
Keep project product names in sync. Renaming a product now updates its name on projects automatically.
Lock pickup and delivery terms on orders. The pickup or delivery choice now locks appropriately on the order screen, and pickup orders support address entry.
Simplify quick project creation. Quick project creation is more reliable and can now be turned on from the admin panel.
Map routes and material usage to the scheduled plant. Order route maps and material usage totals now follow each schedule's plant instead of the order's plant, giving accurate plant level numbers when loads ship from multiple plants.
Bug Fixes
Fix cloning orders with multiple schedules. Cloning no longer fails with a validation error when the source order has several schedules.
Fix contractor order requests without a plant. Order requests submitted without a plant no longer fail for companies using plant based order numbering.
Fix moving tickets to a new project. Tickets in an open accounting period are no longer incorrectly treated as closed when moved, unblocking month end corrections.
Dispatch & Scheduling (All 22)
New Features
Add right click menus to All 22 Dispatch. The familiar Logistics actions are now available directly on All 22 load bars, truck rows, and orders, with quick navigation links, so dispatchers no longer need to switch back to the legacy screens.
Add admin controls for new optimizer settings. The plant form now includes the operator start time offset and service radius fields, and recent All 22 settings appear in the admin configuration form.
Improvements
Cap the lateness penalty. The penalty for a late load can now be capped after a configurable threshold so one very late load does not distort the rest of the plan. Contact support to tune.
Skip trucks without a live GPS signal. For imminent loads, the optimizer no longer assigns trucks that have not reported a recent position.
Weigh remaining capacity in assignments. Plant and truck assignment now considers how much capacity a choice uses up, leading to better decisions when resources are tight.
Show overload demand in Planning charts. The demand charts now include overload demand so staffing gaps are visible at a glance.
Expand plan history tools. Plan snapshots can now be captured for read only plant groups and for tomorrow's plan, making before and after comparisons easier. Contact support to enable.
Keep manual plant choices after ticket edits. Editing a scheduled ticket's plant now automatically enables manual planned plants so the edit sticks.
Bug Fixes
Fix overload handling for first loads. Resolved a case where a truck traveling empty to its first load was not considered before marking the load as an overload.
Fix per yard cost handling. Per yard fixed costs are no longer treated as one time per load charges, improving plan cost accuracy.
Fix missing route data for alternate plants. Eligible orders now get full road route data for alternate plants instead of silently falling back to straight line estimates.
Fix stale truck statuses in Logistics. Events from a previous trip can no longer overwrite a truck's current status, time, and trip context.
Fix early morning assignment ordering. First round protection is now correctly scoped to each plant, and automatic onboarding only considers logged in drivers.
Mix Design Management
Bug Fixes
Fix mix sequences reordering on refresh. Refreshing a schedule can no longer change the saved mix sequence.
Fix unavailable mixes being imported. Mixes marked unavailable in the batch system are no longer imported as orderable.
Invoicing & Integrations
New Features
Detect ticket anomalies before invoicing. Tickets that look unusual compared to a customer's history are now flagged, helping catch billing errors before invoices go out.
Add daily contribution margin reporting. Contribution margin can now be tracked on a daily basis.
Add a billing address option for scale integrations. A new setting controls whether the billing or ship to address is sent on tickets to connected scale systems. Contact support to enable.
Add real time ticket and event push. Tickets and events can now be pushed to connected logistics systems as they happen, configured under Administration Integrations.
Import scheduled tickets and work types from Sysdyne. The Sysdyne integration now brings in scheduled tickets and work types, enabling pour rates and richer scheduling data.
Improvements
Improve billing status workflows. The bulk action and filter panel now offer more billing status options.
Lock prompt pay discount defaults. Default prompt pay discounts now lock the related fields in web and Android forms to prevent accidental edits.
Enrich truck telematics data. Return plants from the telematics feed now flow into return locations, and state job numbers are passed along for compliance reporting.
Allow removing a user from a single organization. An account can now be removed from one organization without affecting the user's access elsewhere.
Speed up high volume integrations. Batch weight processing and event queries are significantly faster, preventing import backlogs and integration timeouts at large operations.
Bug Fixes
Fix duplicated invoices in exports. Integration exports no longer duplicate invoices.
Fix $0 concrete lines on invoices. An interrupted tax calculation during ticket save could zero out a concrete line. Totals are now calculated reliably.
Fix incorrect open balances. Material Now no longer shows an inflated open balance for some customers.
Fix ordered totals after quantity changes. Changing order line quantities from an integrated system now recalculates the order's allocated totals.
Fix the Post-Invoice Report. The Created filter now uses the invoice creation date, the Created tab sends the correct filter, and returned and original invoices are included again so automated GL exports reconcile at month end.
Fix credit hold release. Lifting a customer level credit hold now also releases the customer's projects.
Fix batch weights on defective tickets. Batch weights are viewable again on tickets marked defective.
Fix missing aggregate and bulk tickets. Resolved an issue where some aggregate and bulk tickets did not flow in from the batch system.
Fix batch weight matching for padded ticket numbers. Ticket numbers with leading zeros now match their batch weights.
Fix time zone handling across regions. Operations spanning regions with different daylight saving rules now show correct times throughout.
Other Changes
Update void reason codes. A void reason code was renamed for clarity.
Review margin calculations. Investigated and reconciled reported discrepancies in margin calculations.
Mobile App Experience
Bug Fixes
Fix missing jobs for multi customer users. Material Now users linked to several companies now see their orders on the opening screen on mobile.
Fix single sign on issues. SSO users are now routed to the correct app instead of landing in Material Pro unexpectedly, and iOS sign in no longer fails with a redirect error.
Other Changes
Prepare additional branded apps. Groundwork for new producer branded versions of the mobile apps.
Reliability, Performance & Admin/Settings
New Features
Add a Release Notes page in the web app. Release notes are now viewable directly inside the application.
Restrict visible data by plant group. A user's plant group assignment can now limit which data they see in Material Pro. Contact support to enable.
Improvements
Improve plant group administration. The default root plant group type has changed, and the child type of an empty plant group can now be changed without recreating it.
Other Changes
Strengthen platform reliability. A broad set of behind the scenes stability improvements covering imports, background processing, deployment, monitoring, and automated testing to keep the platform fast and dependable.
Posted Jul 22, 2026 - 14:56 UTC
Completed
The scheduled maintenance has been completed.
Posted Jul 22, 2026 - 07:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 22, 2026 - 06:00 UTC
Scheduled
BCMI will conduct a product update on the following date and time listed below. Product updates require no or very minimal disruption of service and no down time is expected.
Date and Time: July 22, 2026, 0600 UTC (0200 Eastern)
Purpose: Apply fixes, improvements, and stability enhancements to Material Pro and Material Now
Duration: 1 hour
What to expect: Regular access and functionality of Material Pro and Material Now. Virtually no disruption to data import.
Posted Jul 21, 2026 - 10:11 UTC
This scheduled maintenance affected: BCMI Application (Web, Mobile) and API, Database, Third party services.